Commit 70fd1ca6 authored by Amrita Deb's avatar Amrita Deb
Browse files

Merge branch 'rohlfing-patch-remove-pypdf2' into 'master'

Remove pypdf2 from requirements.txt and documents

See merge request !41
parents 7130fa3f 7e9407a5
Pipeline #459584 passed with stages
in 5 minutes and 46 seconds
...@@ -73,6 +73,22 @@ For more info please refer to the [Documentation](https://rwthmoodle.pages.rwth- ...@@ -73,6 +73,22 @@ For more info please refer to the [Documentation](https://rwthmoodle.pages.rwth-
python ./watermark.sh --help python ./watermark.sh --help
``` ```
The current version of code was tested on Windows10, Ubuntu 20.04.1 LTS and macOS 10.14 Mojave to ensure platform independence.The code has the following software dependencies which needs to installed before the programs can be run successfully. Specific version numbers along with categorisation based on script requirement is available [here](Dependancies.md):
* Imagemagick
* Ghostscript
* Python 3.8/3.9
* PIP
* Additional Python modules:
* wand
* pillow
* pwgen
* pikepdf
Instructions to install software dependencies based on your operating system:
* Windows 10 : [Installation of Software Dependencies](swdependencies_win.md)
* MacOS : [Installation of Software Dependencies](swdependencies_mac.md)
* Linux : [Installation of Software Dependencies](swdependencies_linux.md)
### Docker ### Docker
If you are an experienced user familiar with Docker, you can use the provided `Dockerfile` to easily run the scripts. If you are an experienced user familiar with Docker, you can use the provided `Dockerfile` to easily run the scripts.
......
...@@ -8,11 +8,9 @@ Note that all Python packages are listed in the file `requirements.txt`. ...@@ -8,11 +8,9 @@ Note that all Python packages are listed in the file `requirements.txt`.
* Ghostscript 9.53.3 * Ghostscript 9.53.3
* Pillow 8.1.0 * Pillow 8.1.0
* Wand 0.6.5 * Wand 0.6.5
* PyPDF2 1.26.0
## `encrypt.py` ## `encrypt.py`
* PyPDF2 1.26.0
* pwgen 0.8.2.post0 * pwgen 0.8.2.post0
* pikepdf 2.5.0 * pikepdf 2.5.0
......
Wand==0.6.5 Wand==0.6.5
Pillow==8.1.0 Pillow==8.1.0
PyPDF2==1.26.0
pwgen==0.8.2.post0 pwgen==0.8.2.post0
pikepdf==2.5.0 pikepdf==2.5.0
pyzbar==0.1.8 pyzbar==0.1.8
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment