Commit dc0043dc authored by Martin Kröning's avatar Martin Kröning

Generate pkg-config files for pi2-view

parent 895402be
...@@ -13,6 +13,7 @@ ui_resources = gnome.compile_resources( ...@@ -13,6 +13,7 @@ ui_resources = gnome.compile_resources(
'pi2-view-resources', 'data/pi2-view.gresource.xml', 'pi2-view-resources', 'data/pi2-view.gresource.xml',
source_dir: 'data' source_dir: 'data'
) )
pkg = import('pkgconfig')
gtkmm_dep = dependency('gtkmm-3.0', version : '>=3.22.2') gtkmm_dep = dependency('gtkmm-3.0', version : '>=3.22.2')
thread_dep = dependency('threads') thread_dep = dependency('threads')
pi2_view_lib = library('pi2-view', [pi2_view_src, ui_resources], pi2_view_lib = library('pi2-view', [pi2_view_src, ui_resources],
...@@ -20,6 +21,12 @@ pi2_view_lib = library('pi2-view', [pi2_view_src, ui_resources], ...@@ -20,6 +21,12 @@ pi2_view_lib = library('pi2-view', [pi2_view_src, ui_resources],
include_directories: pi2_view_inc, include_directories: pi2_view_inc,
install: true install: true
) )
pkg.generate(
name : 'pi2-view',
description : 'Displays maps of the PI2',
libraries : pi2_view_lib,
subdirs : 'pi2-view'
)
install_headers('include/MapAppABI.h', subdir : 'pi2-view') install_headers('include/MapAppABI.h', subdir : 'pi2-view')
pi2_view_dep = declare_dependency( pi2_view_dep = declare_dependency(
link_with : pi2_view_lib, link_with : pi2_view_lib,
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment