Commit b1ba6c79 authored by hengwen's avatar hengwen

Fix an issue that openjfx won't be installed correctly in current openjdk:8-jdk image

parent 354fbadc
......@@ -2,7 +2,11 @@ FROM openjdk:8-jdk
WORKDIR /app
RUN apt-get update && apt-get install -y openjfx && apt-get install -y metis && rm -rf /var/lib/apt/lists/*
RUN apt-get update && \
apt-get install -y openjfx && \
apt-get install -y metis && \
rm -rf /var/lib/apt/lists/* && \
cp /usr/lib/jvm/java-8-openjdk-amd64/jre/lib/ext/jfxrt.jar /usr/local/openjdk-8/jre/lib/ext/
COPY ./app.jar ./
COPY ./app.db ./classes/app.db
......
......@@ -4,6 +4,6 @@ WORKDIR /app
COPY . .
RUN apt-get update && \
apt-get install -y openjfx && \
apt-get install -y --no-install-recommends openjfx metis && \
cd /app/rpc && \
mvn install -DskipTests -s ../settings.xml
\ No newline at end of file
cp /usr/lib/jvm/java-8-openjdk-amd64/jre/lib/ext/jfxrt.jar /usr/local/openjdk-8/jre/lib/ext/
\ No newline at end of file
......@@ -2,7 +2,10 @@ FROM openjdk:8-jdk
WORKDIR /app
RUN apt-get update && apt-get install -y --no-install-recommends openjfx && rm -rf /var/lib/apt/lists/*
RUN apt-get update && \
apt-get install -y --no-install-recommends openjfx && \
rm -rf /var/lib/apt/lists/* && \
cp /usr/lib/jvm/java-8-openjdk-amd64/jre/lib/ext/jfxrt.jar /usr/local/openjdk-8/jre/lib/ext/
COPY simulator-rpc.jar ./
COPY ./*.fmu ./lib/
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment