Commit ff0bb936 authored by Jean Meurice's avatar Jean Meurice
Browse files

Pom/Settings update

parent 5fb225ad
Pipeline #338752 passed with stage
in 1 minute and 3 seconds
...@@ -7,7 +7,7 @@ ...@@ -7,7 +7,7 @@
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"> <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion> <modelVersion>4.0.0</modelVersion>
<groupId>de.rwth-aachen.se.montisim.simulators</groupId> <groupId>montisim</groupId>
<artifactId>basic-simulator</artifactId> <artifactId>basic-simulator</artifactId>
<version>2.0</version> <version>2.0</version>
...@@ -16,7 +16,6 @@ ...@@ -16,7 +16,6 @@
<properties> <properties>
<!-- USE THESE TO SET THE VERSIONS OF THE DEPENDENCIES FOR ALL THE SUB-PROJECTS --> <!-- USE THESE TO SET THE VERSIONS OF THE DEPENDENCIES FOR ALL THE SUB-PROJECTS -->
<montisim.commons.version>2.0.5</montisim.commons.version> <montisim.commons.version>2.0.5</montisim.commons.version>
<!-- <montisim.controller.version>1.0.4</montisim.controller.version> -->
<montisim.hardware_emulator.version>2.0.0</montisim.hardware_emulator.version> <montisim.hardware_emulator.version>2.0.0</montisim.hardware_emulator.version>
<montisim.simulation.version>3.0.0</montisim.simulation.version> <montisim.simulation.version>3.0.0</montisim.simulation.version>
...@@ -28,56 +27,6 @@ ...@@ -28,56 +27,6 @@
<java.version>1.8</java.version> <java.version>1.8</java.version>
</properties> </properties>
<repositories>
<repository>
<id>mvnrepository</id>
<name>MVNRepository</name>
<url>https://maven.imagej.net/content/repositories/public</url>
</repository>
<repository>
<id>central</id>
<url>https://repo1.maven.org/maven2</url>
<releases>
<enabled>true</enabled>
</releases>
<snapshots>
<enabled>true</enabled>
</snapshots>
</repository>
<repository>
<id>eclipse</id>
<url>https://repo.eclipse.org/content/groups/releases/</url>
<releases>
<enabled>true</enabled>
</releases>
<snapshots>
<enabled>true</enabled>
</snapshots>
</repository>
<repository>
<id>jcenter</id>
<url>https://jcenter.bintray.com/</url>
<releases>
<enabled>true</enabled>
</releases>
<snapshots>
<enabled>true</enabled>
</snapshots>
</repository>
<repository>
<id>topobyte</id>
<url>http://mvn.topobyte.de/</url>
<releases>
<enabled>true</enabled>
</releases>
<snapshots>
<enabled>true</enabled>
</snapshots>
</repository>
</repositories>
<dependencies> <dependencies>
<dependency> <dependency>
<groupId>junit</groupId> <groupId>junit</groupId>
...@@ -85,17 +34,6 @@ ...@@ -85,17 +34,6 @@
<version>4.11</version> <version>4.11</version>
<scope>test</scope> <scope>test</scope>
</dependency> </dependency>
<!-- <dependency>
<groupId>org.glassfish</groupId>
<artifactId>javax.json</artifactId>
<version>1.1.4</version>
</dependency>
<dependency>
<groupId>javax.json</groupId>
<artifactId>javax.json-api</artifactId>
<version>1.1.4</version>
</dependency> -->
<dependency> <dependency>
<groupId>montisim</groupId> <groupId>montisim</groupId>
<artifactId>simulator</artifactId> <artifactId>simulator</artifactId>
...@@ -122,106 +60,11 @@ ...@@ -122,106 +60,11 @@
<version>${montisim.commons.version}</version> <version>${montisim.commons.version}</version>
</dependency> </dependency>
<!--
<dependency>
<groupId>joda-time</groupId>
<artifactId>joda-time</artifactId>
<version>2.9.1</version>
</dependency> -->
<!--
<dependency>
<groupId>de.topobyte</groupId>
<artifactId>osm4j-core</artifactId>
<version>0.0.18</version>
</dependency>
<dependency>
<groupId>de.topobyte</groupId>
<artifactId>osm4j-utils</artifactId>
<version>0.0.22</version>
</dependency>
<dependency>
<groupId>de.topobyte</groupId>
<artifactId>osm4j-xml</artifactId>
<version>0.0.3</version>
</dependency>
<dependency>
<groupId>de.topobyte</groupId>
<artifactId>osm4j-pbf</artifactId>
<version>0.0.7</version>
</dependency>
<dependency>
<groupId>de.topobyte</groupId>
<artifactId>osm4j-tbo</artifactId>
<version>0.0.9</version>
</dependency>
<dependency>
<groupId>de.topobyte</groupId>
<artifactId>osm4j-geometry</artifactId>
<version>0.0.14</version>
</dependency>
<dependency>
<groupId>de.topobyte</groupId>
<artifactId>adt-geo</artifactId>
<version>0.0.2</version>
</dependency>
<dependency>
<groupId>de.topobyte</groupId>
<artifactId>jts2awt</artifactId>
<version>0.0.1</version>
</dependency>
<dependency>
<groupId>de.topobyte</groupId>
<artifactId>mercator-image</artifactId>
<version>0.0.1</version>
</dependency>
<dependency>
<groupId>org.wololo</groupId>
<artifactId>jts2geojson</artifactId>
<version>0.6.0
</version>
</dependency>
<dependency>
<groupId>org.apache.commons</groupId>
<artifactId>commons-compress</artifactId>
<version>1.8
</version>
</dependency>
<dependency>
<groupId>org.slf4j</groupId>
<artifactId>slf4j-api</artifactId>
<version>1.6.1</version>
</dependency>
<dependency>
<groupId>org.slf4j</groupId>
<artifactId>slf4j-log4j12</artifactId>
<version>1.6.1</version>
</dependency>
<dependency>
<groupId>org.jogamp.gluegen</groupId>
<artifactId>gluegen-rt-main</artifactId>
<version>2.3.2</version>
</dependency>
<dependency>
<groupId>org.jogamp.jogl</groupId>
<artifactId>jogl-all-main</artifactId>
<version>2.3.2</version>
</dependency> -->
</dependencies> </dependencies>
<build> <build>
<plugins> <plugins>
<plugin>
<artifactId>maven-deploy-plugin</artifactId>
<version>2.8.1</version>
</plugin>
<plugin> <plugin>
<groupId>org.apache.maven.plugins</groupId> <groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-shade-plugin</artifactId> <artifactId>maven-shade-plugin</artifactId>
...@@ -317,8 +160,25 @@ ...@@ -317,8 +160,25 @@
<workingDirectory>${project.basedir}/install</workingDirectory> <workingDirectory>${project.basedir}/install</workingDirectory>
</configuration> </configuration>
</plugin> </plugin>
<plugin>
<artifactId>maven-deploy-plugin</artifactId>
<version>2.8.1</version>
</plugin>
</plugins> </plugins>
</build> </build>
<!-- == DISTRIBUTION ==================================================== -->
<distributionManagement>
<repository>
<id>se-nexus</id>
<url>https://nexus.se.rwth-aachen.de/content/repositories/embeddedmontiarc-releases/</url>
</repository>
<snapshotRepository>
<id>se-nexus</id>
<url>https://nexus.se.rwth-aachen.de/content/repositories/embeddedmontiarc-snapshots/</url>
</snapshotRepository>
</distributionManagement>
</project> </project>
\ No newline at end of file
...@@ -9,11 +9,6 @@ ...@@ -9,11 +9,6 @@
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0 http://maven.apache.org/xsd/settings-1.0.0.xsd"> xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0 http://maven.apache.org/xsd/settings-1.0.0.xsd">
<pluginGroups>
<pluginGroup>org.mortbay.jetty</pluginGroup>
<pluginGroup>de.topobyte</pluginGroup>
</pluginGroups>
<proxies> <proxies>
</proxies> </proxies>
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment