Unverified Commit 2252e95e authored by dependabot[bot]'s avatar dependabot[bot] Committed by GitHub
Browse files

Bump x86 from 0.40.0 to 0.41.0

Bumps [x86](https://github.com/gz/rust-x86) from 0.40.0 to 0.41.0.
- [Release notes](https://github.com/gz/rust-x86/releases)
- [Commits](https://github.com/gz/rust-x86/commits

)

---
updated-dependencies:
- dependency-name: x86
  dependency-type: direct:production
  update-type: version-update:semver-minor
...
Signed-off-by: default avatardependabot[bot] <support@github.com>
parent 07fe5c41
Pipeline #538404 failed with stages
in 10 minutes and 16 seconds
...@@ -563,15 +563,6 @@ dependencies = [ ...@@ -563,15 +563,6 @@ dependencies = [
"proc-macro2", "proc-macro2",
] ]
[[package]]
name = "raw-cpuid"
version = "9.1.1"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "1733f6f80c9c24268736a501cd00d41a9849b4faa7a9f9334c096e5d10553206"
dependencies = [
"bitflags",
]
[[package]] [[package]]
name = "raw-cpuid" name = "raw-cpuid"
version = "10.2.0" version = "10.2.0"
...@@ -860,7 +851,7 @@ dependencies = [ ...@@ -860,7 +851,7 @@ dependencies = [
"mac_address", "mac_address",
"nix 0.22.0", "nix 0.22.0",
"nom", "nom",
"raw-cpuid 10.2.0", "raw-cpuid",
"rftrace", "rftrace",
"rftrace-frontend", "rftrace-frontend",
"rustc-serialize", "rustc-serialize",
...@@ -1040,13 +1031,13 @@ checksum = "712e227841d057c1ee1cd2fb22fa7e5a5461ae8e48fa2ca79ec42cfc1931183f" ...@@ -1040,13 +1031,13 @@ checksum = "712e227841d057c1ee1cd2fb22fa7e5a5461ae8e48fa2ca79ec42cfc1931183f"
[[package]] [[package]]
name = "x86" name = "x86"
version = "0.40.0" version = "0.41.0"
source = "registry+https://github.com/rust-lang/crates.io-index" source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "702d51a8a099ea6b47826796377591d2ed47116c7f0454f0d08d1d9872944880" checksum = "edcf43654d533a571fe7f7116373098a95ebc01279efdc5038fc45d3b220cb5a"
dependencies = [ dependencies = [
"bit_field", "bit_field",
"bitflags", "bitflags",
"raw-cpuid 9.1.1", "raw-cpuid",
] ]
[[package]] [[package]]
......
...@@ -74,7 +74,7 @@ burst = "0.0" ...@@ -74,7 +74,7 @@ burst = "0.0"
xhypervisor = "0.0" xhypervisor = "0.0"
[target.'cfg(target_arch = "x86_64")'.dependencies] [target.'cfg(target_arch = "x86_64")'.dependencies]
x86 = { version = "0.40", default-features = false } x86 = { version = "0.41", default-features = false }
[dev-dependencies] [dev-dependencies]
criterion = "0.3" criterion = "0.3"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment